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1  What's new
_____________________________________________________________

With USB Meter Reader 4.8 it is now possible to use READy Converter for walk-by/drive-by
reading. For details, see this Video.

Step-by-step instructions can also be found here:

· How to add converters to the system

· How to read meters with a converter

https://youtu.be/Tt63oT0ElNA
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2  Introduction
_____________________________________________________________

USB Meter Reader is a meter reading system used for remote reading of meters with wireless and
wired M-Bus as well as water meters with one-way radio and meters with Kamstrup 434 MHz radio
modules.

2.1   Data security

The USB Reader Meter program is a single-user program to be installed locally on a Windows
computer.

The use of the program must take place through secured procedures on a secure machine.

When the program is used where the EU General Data Protection Regulation (GDPR)* applies,
the user must be authorized to handle personal data as follows:

· Reading of consumption data

· Handling of consumption data

· Export of consumption data

It is recommended to use a password at the start-up of the program.

* Regulation (EU) 2016/679 of the European Parliament and of the Council of 27 April 2016 on the
protection of natural persons with regard to the processing of personal data and on the free
movement of such data, and repealing of Directive 95/46/EC (General Data Protection
Regulation).

2.2   Wireless reading components

Wireless reading includes the following components:

· USB Reader

· Power Pack

· Charging cable

· Quick Guide

USB Reader
USB unit for wireless reading of Kamstrup meters. Connect the unit to a USB port on a Power
Pack, as described below, or on a PC. Alternatively, it is possible to use a cigarette plug with USB.

The USB Meter Reader program can handle a USB Reader for 434 MHz and a USB Reader for
Wireless M-Bus at the same time.

This means that you can read meters with a 434 MHz radio module and meters with Wireless M-
Bus simultaneously.

Power Pack
Power supply for USB Reader. Before using Power Pack, it must be charged. For further
information please see the instructions enclosed with the Power Pack.

It automatically switches on when the USB Reader is connected.

Charging cable
The charging cable is used for charging Power Pack. Connect the little plug to Power Pack and the
big plug to a USB port, e.g. on a PC. The charging time is 3-5 hours, depending on how much
power the USB port can supply.
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Quick Guide
Describes how to download the program Kamstrup USB Meter Reader from Kamstrup’s website
and how to install it on the PC.

2.3   Wired reading components

Wired reading includes the following components:

· Kamstrup M-Bus Master MultiPort 250D or 250L

· Installation and User Guide for M-Bus Master

· USB cable 6699-336 for M-Bus Master

As M-Bus master, it is recommended to use Kamstrup M-Bus Master MultiPort 250D or 250L. The
master must be connected to the PC via the USB cable. When using a RS-232 connection, the
master must be created manually in the program.

2.4   Usage/good practice, wireless reading

This section describes how to use the USB Reader for collecting/reading data wirelessly from
meters in the best way. The first time a meter is read, the reading duration may be longer as some
extra data needs to be collected.

Using Power Pack
When you use Power Pack, the work procedure is as follows:

1. Create a job for the USB Reader that you use with Power Pack. Note:If another USB Reader is
already connected to the PC, you do not need to insert the USB Reader from the Power Pack
into the PC. The job list will be sent to your USB Reader wirelessly.

2. The USB Reader starts the reading as soon as it is in motion (green diode starts to emit light).
Therefore, the USB Reader starts to read when you start walking/driving. Note: There is a
small delay before it starts to read. When the green diode flashes (once per second), you
must stop and wait until it stops flashing. When it stops, you can carry on walking until it starts
flashing again. Continue in this way until you have completed your route.

3. The next time, your USB Reader is in contact with the Kamstrup Meter Reader system, it will
transfer the data to the system. Under "Home", click "USB Reader" to check if meters are
missing. If this is the case, you can transfer the list of the missing meters to your USB Reader
(see how to under "Home").

Pay attention to the "USB Reader" which is connected to a PC
If you use a Power Pack, it is best to keep a distance to the USB Reader which is connected to a
PC. Thus, you avoid that the USB Reader inserted in the PC contacts your USB Reader during the
reading. The USB Reader in the PC will continuously try to collect new data from your USB
Reader. Therefore, each time you collect new data, your USB Reader must return the new data to
the other USB Reader before it resumes the reading sequence. The communication also prevents
the USB Reader from showing "Reading completed" (the orange diode flashes 3 times).

Using a PC for collecting data
The procedure when using the Kamstrup USB Meter Reader system for collecting data is as
follows:
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Collect data from a meter list

1. Create a job for the USB Reader which is inserted in the PC.

2. Click "Reading" on the toolbar, and select the tab "Read meter(s) on USB Reader".

Collect data from a specific meter

1. Click "Reading" on the toolbar, and select the tab "Read specific meter(s)".

2.5   Usage/good practice, wired reading

The establishment of a wired M-Bus network and reading of meters via M-Bus Master MultiPort 250
is described in the installation and user guide for M-Bus Master MultiPort 250.

2.6   Definitions

This section contains the various definitions used in the Kamstrup Meter Reader program.

Missing meters
The definition "Missing meters" is used in the Home and Reading windows. A meter is defined as
missing if the latest reading time is before the definition "Missing meters" (see below). This means
that if, for example, a meter was read on 26/11/2015 and the definition "Missing meters" is set to 2
days (standard), the meter appears in the list of missing meters on 29/11/2015. If the definition
"Missing meters" is changed to 14 days, the meter appears in the list of missing meters on
11/12/2015.

The definition "Missing meters"
The number of days after which the data is considered as old. If the definition "Missing meters" is
set to e.g. 2 (standard) and today’s date is 20/10/2015, all data from 17/10/2015 as well as earlier
data will be considered as old. The value can be entered under File > Setup. Meters which have
been read prior to the pre-programmed number of days will appear from the list of missing meters.

Time of receipt
The time of receipt is the time when the Kamstrup USB Meter Reader system receives data from a
USB Reader. Therefore, if you read data on e.g. 08/08/2015 and do not return to the office on the
same day (but e.g. the following morning), the date of the "Latest reading" will be 09/08/2015. 

Job / Job list
A job or job list is a list of meters that a USB Reader must read. To create a job (a job list), click
Job lists in the toolbar and create the job in the New job window.
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3  Basic working procedures
_____________________________________________________________

Step-by-step instructions on how to perform the most common tasks in USB Meter Reader are
found below. 

What do you want to do?
Meters

· Add meters to USB Meter Reader

· Remove meters from USB Meter Reader

· Rename a meter

· Add addresses to meters

· Organise meters in groups

Data collection units

· Add a converter to USB Meter Reader

· Add an M-Bus master to USB Meter Reader

Reading of meters

· Read meters with a converter

· Read meters via an M-Bus master

· See meter readings

Heat supply

· Dis- and reconnect heat supply

Data export

· Export meter readings

Program

· Activate add-on features

3.1   How to add meters

There are three ways of adding meters to the system:

· To import meters from a KEM file (you have received an email from Kamstrup with a link to the
KEM file that you download to your PC), follow this procedure.

· To import meters from My Kamstrup (you have a user login to Kamstrup's customer portal, My
Kamstrup, from which the program automatically collects the required information), follow this
procedure.

· To manually create meters (only used for wired M-Bus reading of unencrypted meters - i.e for
meters that are wired to an M-Bus master), follow this procedure.
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3.1.1   Import meters from KEM file

Prerequisite: You have received an email from Kamstrup with a link to a KEM file (the file name
consists of a long string of numbers and letters and ends with "zip.kem") and you have
downloaded the KEM file to your PC. 

1. In the toolbar, select Meters:

2. In the Edit meter window that appears, select Add:
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3. Select Import meter(s) from KEM file.
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4. In Customer number / Password, enter the password you have received for the KEM file.

Typically, you have received the password via SMS.

5. Select Import.

6. Browse to and select the file. Click Open.
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7. Click OK in the message that appears:

8. Click Close wizard.

Errors that may occur while importing the KEM file
If you cannot import the KEM file, it may be due to one of the following errors:

Error message Cause

The password may have been
entered incorrectly. Try to enter the
password again. If the problem
persists, please contact Kamstrup
A/S.

The system can contain a
maximum of 800 meters (4,000
meters if you have a licence). If this
limit is exceeded, the system will
import up to 800/4,000 meters. The
remaining meters will not be
imported.

If an error has occurred while
generating the file, or if the KEM file
has been changed, the meters in
this file cannot be imported. Please
contact Kamstrup A/S to receive a
new file.
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3.1.2   Import meters from My Kamstrup

Follow the steps below to add one or more meters to USB Meter Reader:

1. In the toolbar, select Meters:

2. In the Edit meter window that appears, select Add:



USB Meter Reader

15/106Kamstrup A/S • 5512839_K1_EN_06.2022_KARN

3. Select Import meter(s) from My Kamstrup:
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4. Enter your user name and password to My Kamstrup:

By default, only meters that are not already in USB Meter Reader will be imported. To import all
meters (and overwrite meters that are already in USB Meter Reader), select Import all
meters.

5. Select Import.
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6. Click OK in the message that appears:

7. Click Close wizard.

3.1.3   Manually create unencrypted meters

Follow the steps below to manually add one or more meters to USB Meter Reader:

1. In the toolbar, select Meters:

2. In the Edit meter window that appears, select Add:
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3. Select Manual:

4. In Manufacturer ID, select the following depending on the meter type you want to add:

· Kamstrup heat meter: KAM

· Kamstrup water meter of the type MULTICAL® 21, flowIQ® 21xx or flowIQ® 3100: KAM

· Kamstrup water meter of other types: KAW
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5. Enter a meter serial number in Meter serial number from to add a single meter. To add more
consecutive numbered meters, enter the lowest serial number in Meter serial number from
and the highest number in Meter serial number to:

6. Select Add.

7. Select OK in the message that appears:
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8. Select Close wizard.

3.2   How to add converters

Converters  are used for drive-by/walk-by reading of your meters. 

In order to use the converter, it must be added to USB Meter Reader so that you can:

· add the meters you want to read to the converter

· transfer meter readings from the converter to USB Meter Reader when the meters have been
read.

The communication between USB Meter Reader and the converter takes place either:

·  via cable (by plugging the USB cable that came with your converter into the PC on which USB
Meter Reader is installed)

· or via wireless Bluetooth connection

How to add a new converter to USB Meter Reader

· If you want to be able to communicate with USB Meter Reader both via cable and via wireless
Bluetooth connection, follow this procedure.

· If you want to communicate with USB Meter Reader via cable only, follow this procedure.

3.2.1   Adding a converter with Bluetooth connection to PC

Follow the steps below to add a converter to USB Meter Reader:

1. Turn on the converter by pressing the button on the front of the converter.

2. In the toolbar, select Converters:
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3. In the Converters window that appears, select Add Bluetooth converter:

If the Add Bluetooth converter button is unavailable (dimmed), it means that Bluetooth
communication is deactivated on your PC. If so, go to start menu > Settings > Devices and
turn on Bluetooth:

Close USB Meter Reader and open it again, for the new setting to take effect.



USB Meter Reader

22/106Kamstrup A/S • 5512839_K1_EN_06.2022_KARN

4. In the window that appears, select the converter that appears in the list, and click Add:

If in doubt, check that the serial number (S/N) on the back of the converter matches the
converter you select. 

5. Enter a name for your converter and click Add:
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6. Click the message the appears at the bottom of your pc screen:

7. In the Pair Device window that appears, click Allow:
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8. In the message that appears, click Yes:

9. In the Result window that appears, click OK.

10. Click Close in the Pair Device window.
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In the Converters window, you can now see that Bluetooth communication has been enabled
for the converter:

11. Click OK.

3.2.2   Adding converter with cable connection to PC

Follow the steps below to add a converter to USB Meter Reader:

1. Plug the converter into your PC with the USB cable that came with your converter.

2. In the window that appears, enter a name for your converter and click Add:
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3. In the message that appears, click Yes:

The converter is now added to USB Meter Reader:

3.3   How to add M-Bus masters

Note An M-Bus Master licence for USB Meter Reader is required to add an M-Bus master to the
system.

Follow the steps below to add a new M-Bus master:

1. Plug the USB cable from your M-Bus master into your PC.
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2. In the New M-Bus Master window that appears, enter a name for your M-Bus master:

If a red error icon appears in the Name field, the name already exists and cannot be used.

3. Click OK.

3.4   How to create a reading job

Follow the steps below to create a reading job with the list of meters you want to read:

1. In the toolbar, select Job lists:
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2. In the top right corner of the New job window that appears, select the converter or M-Bus
master for which you want to create a reading job:

3. In the All Meters list to the left, select the meter groups or meters you want to read with the

converter/M-Bus master and click  to add them to the reading job. To remove meters from

the reading job, select the meters in the list to the right and click .

4. Click Save job.

3.5   How to read meters with a converter

When you read meters with a converter, you drive (or walk) past the houses where the meters are
installed. The drive-by reading takes place in one of the following ways:

· Stand-alone reading: You only use the converter when driving around to read your meters.

· Reading via PC: You start and follow the reading via USB Meter Reader on your PC (meaning
you bring both your PC and your converter when driving around to read your meters).

Important The very first time you read your meters with a converter, make sure to read them
via PC in order to register basic information about the meter reading correctly in the
system.
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3.5.1   Stand-alone reading

Follow the steps below to read meters using the converter only:

1. Make sure that USB Meter Reader is open on your PC and the converter is turned on.

If you plug the converter into your PC it turns on automatically. If you use the wireless
Bluetooth connection, press and hold the button on the front of the converter until the green
lights turn on - and keep it near the PC.

2. In the toolbar, select Job lists:

3. In the New job window that appears, select the converter in the top right corner:

4. Use the add  and remove  buttons to create the list of meters you want to read with the
converter (list to the right).

5. Click Save job.

6. Start the reading by pressing the button on the front of the converter quickly twice followed by a
long press (approx. 4 seconds).

The green light starts flashing on the converter. Each time a meter is read, the green light
flashes twice with double speed. When the green light starts flashing slowly, all meters have
been read.
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Your data will be transferred to USB Meter Reader, the next time the converter connects to USB
Meter Reader. You can see the data by selecting Data in the toolbar in USB Meter Reader.

3.5.2   Reading via PC

Follow the steps below to read meters using both the converter and the PC:

1. Make sure that USB Meter Reader is open on your PC and the converter is turned on.

If you plug the converter into your PC it turns on automatically. If you use the wireless
Bluetooth connection, press and hold the button on the front of the converter until the green
lights turn on - and keep it near the PC.

2. Select Reading in the toolbar, and check that the correct list of meters is saved in the
converter. If not, create a new reading job list for the converter (for details, see How to create a
reading job).

3. Select Start reading in the toolbar:

You can now follow the progression of the reading and see which meters still need to be read.
You can also stop or pause the reading from the toolbar:



USB Meter Reader

31/106Kamstrup A/S • 5512839_K1_EN_06.2022_KARN

When the reading is completed, the following window appears:

5. Click OK and select Data in the toolbar to see the reading data.

3.6   How to read meters with an M-Bus master

Note An M-Bus Master licence for USB Meter Reader is required to read meters wired to an M-
Bus master.

The reading takes place in one of the following ways:

· Manually: You start the reading manually from USB Meter Reader. For details, follow this
procedure.

· Automatically: the reading takes place automatically according to a reading schedule that you
have set up. For details, follow this procedure.

3.6.1   Manual M-Bus reading

Prerequisites: The M-Bus master(s) must be connected to USB Meter Reader.

Follow the steps below to read meters connected to an M-Bus master:

1. Select Reading in the toolbar, and check that the correct list of meters is going to be read. If
not, create a new reading job for the M-Bus master (for details, see How to create a reading
job).

2. Select Start reading in the toolbar:
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You can now follow the progression of the reading and see which meters still need to be read.
You can also stop the reading from the toolbar:

When the reading is completed, the following window appears:

5. Click OK and select Data in the toolbar to see the reading data.

3.6.2   Automatic M-Bus reading

Prerequisites: For automatic meter reading to work, the M-Bus master(s) must be connected to
USB Meter Reader, and a reading schedule must be set up.

Note Only meters that are wired to the active M-Bus master(s) and included in the current
reading job of the M-Bus master(s) will be automatically read.
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How to set up a reading schedule

1. In the toolbar, select Scheduling:

2. In the Schedule options window that appears, select the desired reading interval:

3. Turn on Automatically start scheduled reading on program start.

The reading takes place automatically at the scheduled time if the program is open at that
time. If not, the reading starts automatically when you open USB Meter Reader.

If you turn off Automatically start scheduled reading on program start, no automatic meter
reading takes place.

4. Click OK.

3.7   How to see meter readings

Note Only the latest meter reading for each meter is visible in USB Meter Reader. However, if
you have the Import/export of meter data licence, you are able to export all readings for the
time period that you select.

Follow the steps below to see the latest meter readings for all meters:

1. In the toolbar, select Data:
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The latest reading for each meter now appears:

2. To only see the meter readings belonging to a specific device (converter/M-Bus master) or
meter group, select the device/meter group in the Show only field.

3. To see more data from the latest reading, select Detail v iew and use the Navigation arrows
to browse through the meters in Detail v iew:

For details about how to sort and adjust the columns in list view, click here.
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3.8   How to export meter readings

Note An Import/export of meter data licence is required to export all readings for selected
meters in a selected period. Otherwise you will only be able to export the latest reading for
all meters.

How to export latest reading for all meters

1. In the toolbar, select Data:

2. In the toolbar, select Export:

3. Browse to the desired folder and enter a name for your export file.

4. Select the desired file format and click Save.

By default, reading data can be exported in the following formats: XLS, XLM, TXT, CSV and
PDF.

How to export all readings for one or more meters in a selected period

1. In the toolbar, select Data:

2. In the toolbar, select CSV/TXT Export:

3. In the Meter data export window that appears, select whether you want to export All meters,
selected meters (Custom list) or a meter group.

4. In Time limits, select the time interval for which you want to export readings.

5. In Format, select a previously defined export and go to step 14. Otherwise follow the steps
below to define an export format.

6. In Separator, select the character you want to insert between all meter values to separate
them (typically semicolon or comma).

7. In Only the latest reading check box, select if you want to export all readings (turned off) or
only the latest reading (turned on) in the selected time interval.

8. In Date format, select the format in which you want to export dates.

9. In Property, select the meter value you want to export.
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10. In Index, enter a number for the meter value to indicate the sequence of exported values.

11. In Exclude unit, select whether you want to include units of measurement (turned off) or not
(turned on) in the export file

12. In Split value and unit, select whether you want to insert a separator between the value and
unit (turned on) or not (turned off)

13. Select Export. 

14. Browse to the desired folder and enter a name for your export file.

15. Select the desired file format and click Save.

By default, reading data can be exported in TXT or CSV format.

3.9   How to dis- and reconnect heat supply

Note A Thermal Disconnect licence for USB Meter Reader is required to disconnect and
reconnect the heat supply.

Only the heat supply of meters that fulfill the following criteria can be dis- and reconnected:

· The meter must be a MULTICAL® 403, 603 or 803 meter

· The meter must be read by an M-Bus master

· The meter must be equipped with a HC-003-22 module connected to a thermal actuator

· The meter must be configured for “controlled outputs” (the PP configuration of the meter is set
to 99)

How to set up a meter as a thermal disconnect meter in USB Meter Reader

1. In the toolbar, select Meters:
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2. In the Edit meter window that appears, select the TDS check box for the meter in question
and click OK:

How to disconnect or reconnect the heat supply for a meter

1. In the toolbar, select TDS:
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2. In the Thermal Disconnect window that appears, select the meter for which you want to dis-
or reconnect the heat supply:

3. Follow step a or b:

a. To disconnect the heat supply, select Close.

OR

b. To reconnect the heat supply, select Open.

4. Click OK to confirm.

3.10   How to work with meters

Once you have added meters to USB Meter Reader, you can

· Add addresses to meters

· Organise meters in groups

· Add meters and meter groups to reading jobs

· See reading for a meter

· Rename meters

· Delete meters
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3.10.1   How to add addresses to meters

There are two ways of adding addresses to your meters:

· Import a file in TXT or CSV format, e.g. from your billing system, with meter serial numbers
and address information. (Requires an Import/Export add-on to USB Meter Reader).

· Manually enter addresses for your meters.

3.10.1.1   Importing addresses

Note An Import/Export licence for USB Meter Reader is required to import meter addresses.

Prerequisite: A file with addresses and meter serial numbers in TXT or CSV format, e.g. from your
billing system, must be created in advance. An example with house number, street name and
meter serial number is shown below: 

1. In the toolbar, select Meters:
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2. In the Edit meter window that appears, select Add:



USB Meter Reader

41/106Kamstrup A/S • 5512839_K1_EN_06.2022_KARN

3. Select Import meter data:

4. Browse to and select the TXT or CSV file with your meter addresses. Click Open.
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The Meter data import window appears:

5. In Separator, select the character (typically semicolon or comma) used to separate import
values in your file. 

6. If you only want to import part of your file, select Use line limits and enter the line numbers to
include in the From line and To line fields.

7. In Property, select the first value in your file, e.g. 'House number', enter '1' in the Index field

and click .

8. In Property, select the second value in your file, e.g. 'Street', enter '2' in the Index field and

click . 

9. Repeat step 8 for each value in your file.

10. If you want the house number before the street name, select Set house number before
street.

11. Click Import.
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If your file does not contain a manufacturer ID, a warning message appears:

12. Click OK if your meter serial numbers are unique without the manufacturer ID or the ID has
already been imported with the meter. Otherwise abort the import and add a manufacturer ID
to your import file.

13. Click OK in the import result message that appears:

14. If you want to save the import format you have just created, click Yes and follow step 15.
Otherwise click No and go to step 16:
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15. Enter a name for your import format and click Save:

16. Click Close wizard.

3.10.1.2   Entering addresses

Follow the steps below to manually enter meter addresses in USB Meter Reader:

1. In the toolbar, select Meters:
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2. In the Edit meter window that appears, double-click the meter to which you want to add an
address:

3. Enter the address and press the RETURN key.

4. When you are done entering the desired addresses, click OK.

3.10.2   How to organise meters in groups

Meters can be organised in groups. Typically you would group meters according to geographical
areas to create logical reading groups. In this way you can easily create reading jobs for your drive-
by readings. 

A meter can be part of more than one group, if desired.

What do you want to do?

· Create a meter group

· Change a meter group

· Delete a meter group
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3.10.2.1   Creating a meter group

Follow the steps below to create a new group of meters:

1. In the toolbar, select Groups:

2. In the New group window that appears, Click Create:

3. Enter a name for your new group, and click Save:
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4. In the All Meters list to the left, select the meters you want to add to the group and click :

 

5. Click OK.

6. Click Yes to confirm saving the new group:
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3.10.2.2   Changing a meter group

Follow the steps below to add meters to or remove meters from a meter group:

1. In the toolbar, select Groups:

2. In the New group window that appears, select the group you want to change:

3. In the All Meters list to the left, select the meters you want to add to the group and click

. To remove meters from the group, select the meters in the list to the right and click

. 

4. Click OK.
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5. Click Yes to save your changes:

3.10.2.3   Deleting a meter group

Follow the steps below to delete a meter group:

Note Only the group will be deleted. The meters in the group are not deleted. To delete meters,
see How to delete a meter.

1. In the toolbar, select Groups:

2. In the New group window that appears, select the group you want to delete:
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3. Click Delete:

 

4. Click OK to confirm the deletion:

5. Click OK to close the New group window.

3.10.3   How to rename a meter

Follow the steps below to rename a meter:

1. In the toolbar, select Meters:
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2. Double-click the meter you want to rename:

3. Enter the new name, and press the RETURN key on your keyboard.

4. Click OK.

3.10.4   How to delete a meter

Follow the steps below to delete a meter:

1. In the toolbar, select Meters:
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2. In the list of meters, select the meter you want to delete and click Delete:

3. In the message that appears, click OK to confirm:

4. Click OK to close the Edit meter window.
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3.11   How to activate add-on features

It is possible to buy licences for add-on features in USB Meter Reader. 

Follow the steps below to activate an add-on features:

1. Choose Help menu > Licence.

2. In Feature, select the add-on feature you want to activate:

· Import/export of meter data: lets you import meter addresses and export readings for
selected meters and selected periods.

· M-Bus Master: lets you read meters wired to an M-Bus master

· Metering points: lets you add up to 4,000 meters in USB Meter Reader.

· Thermal Disconnect: lets you disconnect and reconnect the heat supply for MULTICAL®
403, 603 and 803 meters read in a wired M-Bus network. (Requires an M-Bus module HC-
003-22 installed in the meter that is connected to a thermal actuator)

3. Make sure Online activation is selected.

If your computer with USB Meter Reader has no internet connection, click Offline activation
and follow the on-screen instructions.

4. In Online activation enter the licence key received from Kamstrup.

5. Select Activate licence now.
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6. Click OK in the message that appears:
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4  Main window overview
_____________________________________________________________

This section describes the menus, toolbar, views and windows in USB Meter Reader.

4.1   Menu bar

The menu bar consists of 4 menus: File, View, Edit and Help.

The menu File
The File menu  contains 4 submenus. Click the links to see a detailed description.

1. Set-up is used for changing settings such as language, definition of missing meters, etc.

2. Backup is used for making backup copies of all data and configurations or for restoring data.
The function can also be used in connection with the replacement of a computer.

3. Export is only available if you are in the Data view in the toolbar (described briefly below) and is
used for exporting all saved data to e.g. a PDF file.

4. Print is likewise only available if you are in the Data view in the toolbar (described briefly
below). Clicking this opens the Print Preview window.

5. With Delete readings, reading data from all meters in the database can be automatically
deleted when it exceeds a certain age. It is also possible to delete reading data for a single or
multiple meters. Note that the latest reading is never deleted.

6. Exit closes the program.
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The View menu
The View menu contains 3 submenus representing the three depending views that are used in
Kamstrup USB Meter Reader. Click the links to see detailed information about each view.

1. Home is the start window of Kamstrup USB Meter Reader

2. Data provides you with a detailed overview of all your meters

3. Reading is used for collecting data/reading meters.

The Edit menu
This menu contains 4 submenus. The menu is used for adding/editing or deleting USB Readers or
meters in your system. Click the links below to get a detailed introduction to the windows.

1. In USB Readers, you can delete or change the name of a USB Reader in your system

2. In Masters, you can edit the name of and configure connected M-Bus masters

3. In Meters, you can add/edit and delete meters

4. In Groups, you can create or delete a group of meters

5. In Thermal Disconnect, you open and close a thermal actuator connected to M-Bus module
HC-003-22

6. In Job lists, you can select the meters to be read by a specific USB Reader.

7. In Scheduling, you set at which times automatic meter reading must be carried out.
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The Help menu
The Help menu contains 4 submenus: Contents, Licence, About and Online support. Click the
links to see a detailed description.

1. Contents opens the online help

2. Licence is used for installing further functionality

3. About opens a window where you can see the current software version and the product
number of Kamstrup USB Meter Reader.

4. Online support is only used by Kamstrup Metering Service

4.2   Toolbar

The toolbar consists of the following three parts:

1. View
2. Edit
3. File

View
View consists of 3 buttons. The buttons symbolise the various views in Kamstrup USB Meter
Reader. Click the links to see detailed information about each view.

1. Home is the start window of Kamstrup USB Meter Reader

2. Data provides you with a detailed overview of all your meters

3. Reading is used for collecting data/reading meters.
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Edit
This section contains 5 buttons used for adding/editing or deleting USB Readers or meters in your
system. Clicking a button in this section opens a new window. Click the links below to get a
detailed introduction to the windows.

1. In USB Readers, you can delete or change the name of a USB Reader in your system

2. In Masters, you can configure, delete and change the names of M-Bus masters in the system. 

3. Meters is the window where you can add/edit and delete meters

4. In Groups, you can create or delete a group of meters

5. In Thermal Disconnect, you open and close a thermal actuator connected to M-Bus module
HC-003-22

6. In Job lists, you can select the meters to be read by a specific USB Reader.

7. In Scheduling, you set at which times automatic meter reading must be carried out

File
This section is only available in the Data view (see above). Here, you can export or print all your
meters’ data.

1. Export is used for exporting tables to either XLS, PDF or CSV formats. Select destination, file
name and file type in the Save meter data in file window.

2. CSV TXT Export is used for exporting meter data in definable formats. This function requires
that the corresponding licence key is installed.

3. Clicking Print opens the Print Preview window. You can also open this window by clicking

File > Print.
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4.3   Views

This section contains a detailed description of each view in Kamstrup USB Meter Reader:

· Home

· Reading

· Data

4.3.1   Home

The Home (or "live") view is the starting window of your Kamstrup USB Meter Reader program.
The window includes an overview of the USB Readers, converters and M-Bus masters in your
system. This section explains in detail what you can see and do in "live view".

· Overview of Home ("live") view

· Missing meters

Overview
Every time you start the Kamstrup USB Meter Reader program you will see a "live view". The live
view includes a list of USB Readers, converters and M-Bus masters (empty if none have been
installed) and finally the Missing meters window. The two elements appear from the screen
display below where

1. is the list of USB Readers, converters and M-Bus masters in the system.

2. to the right, shows the list of missing meters.
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The list of USB Readers, converters and M-Bus masters
The list of USB Readers, converters and M-Bus masters can be seen in the middle of the screen
display. The units which are not connected to the PC or out of reach will be grey. USB Readers,
converters and M-Bus masters cannot be connected at the same time. The list includes various
details on the connected units. Some of them are shown in the picture below where

1. These units are connected and active.

2. The signal strength is shown in the picture. If the USB icon is visible, it means that the USB
Reader is directly connected to the PC via the USB port.

3. The M-Bus masters are grey as they are currently not connected to the PC.

USB Reader status icons
Each USB Reader has one or more status icons. These represent:

1. The USB Reader is updated. The job list is updated, and all meter data on the USB Reader
has been collected and saved.

2. The job list on the USB Reader is too old and is being updated. Note that the list is updated
automatically

3. The USB Reader contains new data. The system remembers this data continually. Note: This
takes place automatically.

4. USB Reader with internal antenna

5. USB Reader with external antenna.
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The Missing meters window
Missing meters are meters in a USB Reader or M-Bus master job list which are older than the
specified number of days (the definition of "missing meters" is by default 2 days). If you click a USB
Reader or an M-Bus master, the Missing meters window will be updated and show:

1. The name of the USB Reader/M-Bus master

2. A list of meters defined as missing (older than the specified number of days)

3. The Send list to USB Reader button which collects the missing meters and sends them to the
USB Reader or M-Bus master, respectively. Note that the job list will be overwritten and
subsequently only include missing meters.

4. The number of missing meters

5. The Print button that opens the Print Preview window. Here, you can print the list of missing
meters.
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4.3.2   Data

The Data view lets you can see the latest reading data for each meter. This section describes how
to sort, filter and keep an eye on detailed information about the meters in your Kamstrup USB
Meter Reader system.

Topics:

· Opening the Data view

· Overview of the Data view

· View modes

· Using the filter to sort data in USB Reader or in a meter group

· Getting more out of the Data view – sorting and adjusting columns

· Exporting data to a PDF or Excel file

Changing to the Data view
You can change to the Data view by clicking Data in the toolbar, as shown below, or via the menu
Show > Data.

Overview
An image of the Data view is shown below. All the below items are described in more detail later.

1. A list of meters and the most common data

2. In the Views area, you can change between List view and Detail view

3. In the Show only area, you can change the list to include only the meter(s) belonging to a
single job or a group of meters.

4. Use the navigation buttons to browse through the list. They are especially useful in Detail view.

5. An image of the meter type selected on the list. Note: The image is also updated in Detail view

6. All data can be exported and/or printed.
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List view
You can change to List v iew in the area Views (see item 2 above). In List v iew, you can gain an
overview of the meters in your Kamstrup USB Meter Reader system. Navigate through the meters
on the list by using the arrow keys on your keyboard or in the Navigation area (item 4 above).
Note: All changes in the list are saved and available after restart. The view can be reset under File
 > Setup.

Sorting the list according to jobs
In the Show only area, you can change the list to only contain a specific "USB Reader" job list or
the meters in a specific meter group. Note: The number of columns can change as only used
columns are shown.
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Adjusting columns
If you need to adjust the column width or change the order, you can do this in the following ways:

1. To make the column width fit the data width or the width of the heading, left-click with the
mouse in the area between two columns as shown below.

2. To change the width of a column, click and hold down the left mouse button (between 2
columns as shown below). You can now change the width by moving the mouse to the right or
to the left.

3. You can also move the columns around and place the ones you use most next to each other
at the front. To do this, left-click the column heading and move the column to the wanted
position while keeping down the button. This is shown below where the Meter type column is
moved to the first position.
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Sorting columns
To gain the full benefit from the Data view, you can sort the table according to one or more
columns. This is very useful and enables you to group your meters as desired. To sort according
to e.g. meter type, drag the Meter type column to the "column sorting area" and drop it as shown
below.

To sort according to another column, e.g. consumption type, drag the Consumption type column
to the "column sorting area" as shown below.
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It is also easy to change the order of the sorting columns. Just place e.g. the Consumption type
column in front of the Meter type column to sort according to name. This is shown below.
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Detail view
You can change to Detail v iew in the Views area. In Detail v iew, you can see all data collected
from a specific meter.

1. Select Detail v iew in the Views area.

2. In the Navigation area, you can shift between the meters. The buttons navigate to first,
previous, next and last meter, respectively.

3. Note: If you have selected e.g. USB Reader in the Show only area, you only navigate in the
filtered list.

4. Meter number

5. Meter name.

4.3.3   Reading

The Reading window is used for reading selected meters. It has two tabs: Read meter(s) v ia
USB Reader or Read meter(s) v ia M-Bus Master and Read selected meter(s). This section
explains in detail what you can see and do in the Reading window.

Topics:

· Changing to the Reading view

· Overview of Reading

· Using Read meter(s) on USB Reader and Read meter(s) on M-Bus Master, respectively

· Using Read specific meter(s).
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Changing to the Reading view
You can change to the  Reading view by clicking Reading in the toolbar as shown below or via the

menu Show  > Reading.

Overview
In the Reading view, you can change between two tabs depending on type of reading. An
illustration of a USB Reader or an M-Bus network reading data from meters is displayed during
reading. The components are shown below.

1. The two tabs Read meter(s) on USB Reader or M-Bus Master and Read specific
meter(s).

2. The Start and Stop buttons.

Collecting data from meters via USB Reader and M-Bus master, respectively (the tab
Read meter(s))
Select the Read meter(s) tab when reading/collecting data from Job lists in USB Reader or M-
Bus Master that is currently connected to the computer. In order to start reading, click Start. Note
that the USB Reader does not necessarily read the meters in the same order as listed, but rather
one at a time as the USB Reader obtains contact with them. The M-Bus master reads the meters
that support the fastest communication speed first.

While you read, the window will continuously keep you updated on the process:

1. Click Start to start the reading. You can always stop a reading by clicking Stop.
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2. The process bar shows the number of meters that have not been read and the total quantity to
be read.

3. Info: Displays the info codes of the read meters, if any. If you hold the mouse over the !,
further details are displayed

4. The Meter read icon indicates that the meter has been read.

5. The picture is shown as long as the USB Reader or the M-Bus master reads meters.

6. Street(s) to visit: Select Show all streets or Select streets automatically.
If you select Show all streets, all meters to be read are displayed. If Select streets
automatically is shown, only the meters on the street which has just been read or the street
which is being read is displayed.

7. If you select Show only remaining meters, just the meters that have not yet been read are
displayed. Otherwise, all meters, both those read and those not read, are displayed.

When you stop the reading by clicking Stop, or if the reading is stopped automatically when all
meters have been read, the status of the reading is shown. Likewise, any meters which have not
been read or meters with info codes are shown.
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Reading of data from a specific meter (the 'Read specific meter(s)' tab)
Use the Read specific meter(s) tab if you want to read/collect data from a specific meter. To read
data from a meter, select the meter to read from the list and click Start.

1. The meter, which you try to read/from which you try to collect data, is the one selected from
the list.

2. The "meter read" icon shows that the meter is not a "missing meter". Therefore, the "meter
read" icon is added to the meter if the reading succeeds

3. The picture is displayed while you attempt to read the meter.

4. Info. Displays the info codes of the read meters, if any. If you place the mouse over the
individual meter’s info, further details are shown.
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Depending on the result of the reading, a message appears informing you that the reading
succeeded or that the USB Reader could not read the meter.

4.4   Windows

This section describes in detail each window in USB Meter Reader.

· The New USB Meter Reader window

· The New M-Bus Master window

· The Edit USB Meter Reader window

· The Edit M-Bus Master window
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· The Edit Meter window

· The New group window

· The Import of meter data window

· The Export of meter data window

· The New job window

· The Setup window

· The About window

4.4.1   The New USB Meter Reader window

When you insert a new USB Reader into your PC, the New M-Bus Master window shown below
will be displayed. This section describes how to add a new USB Reader to a system.

Topics:

· Naming a USB Reader

· Cancelling changes

· Saving changes.

Naming a USB Reader
When the New USB Meter Reader window is shown (see below), enter a random name for the
"USB Reader" in question. 

If you enter a name that already exists, the red error icon shown below is displayed. To solve the
problem, you can either choose a different name or remove the new USB Reader, delete the old
one and reconnect the new USB Reader.
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Cancelling changes
To cancel your changes, click Cancel.

Saving changes
To save your changes, click OK.

4.4.2   The New M-Bus Master window

When you connect a new M-Bus master to your PC, the New M-Bus Master window shown
below will be displayed. This paragraph describes how to add a new M-Bus master to a system.

Topics:

· Naming M-Bus master

· Cancelling changes

· Saving changes.

Naming an M-Bus master
When the New M-Bus Master window is shown (see below), enter a random name for the
master in question.

If you enter a name that already exists, the red error icon shown below is displayed. To solve the
problem, you can either choose a different name or remove the new M-Bus master, delete the old
one an reconnect the new M-Bus master.
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Cancelling changes
To cancel your changes, click Cancel.

Saving changes
To save your changes, click OK.

4.4.3   The Edit USB Meter Reader window

You can use the Edit USB Meter Reader window for either changing the name of a random USB
Reader in the system or deleting a USB Reader. This section describes step-by-step how to
change the name of or delete a USB Reader.

Topics:

· Opening the Edit USB Meter Reader window

· Changing the name of a USB Reader

· Deleting a USB Reader

· Cancelling changes

· Saving changes.

Opening the Edit USB Meter Reader window 
You can open the window by clicking "USB Readers" in the toolbar or via the menu Edit > USB
Readers.

Changing the name of a USB Reader
In order to change a name, click Edit or double-click the name that you want to change. You can
change the names of as many USB Readers as you want – to edit the next USB Reader, repeat
the procedure.
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Deleting a USB Reader
You can delete a USB Reader by selecting the one that you want to delete and clicking Delete.

Cancelling changes
To cancel your changes, click Cancel.

Saving changes
To save your changes, click OK.

4.4.4   The Edit M-Bus Master window

The Edit M-Bus Master window is used for changing the names of, configuring and deleting M-
Bus masters in a system.

If Kamstrup M-Bus Master 250 is used via USB cable, the master is automatically detected and
created. If other masters are used or Kamstrup M-Bus Master 250 is connected via RS-232, the
master must be created manually.
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Topics:

· Opening the Edit M-Bus Master window

· Changing the name of an M-Bus master

· Selecting maximum baud rate of an M-Bus master

· Using SND_NKE in an M-Bus master

· Showing whether an M-Bus master is connected

Opening the Edit M-Bus Master window
You can open the window by clicking Masters in the toolbar or via the menu Edit > Masters.

Changing the name of an M-Bus master
In order to change the name, click the Edit button and then the name you wish to change.

You can change the names of as many M-Bus masters as you want – to edit the next M-Bus
master, repeat the procedure.

Selecting maximum baud rate of an M-Bus master
The default maximum baud rate is 9600 Baud which can, however, be reduced to 2400 Baud or
300 Baud. This can be an advantage in installations with long cables where 9600 Baud may not
provide stable readings or in systems in which none of the connected meters support 9600 Baud.
In such cases, a lower maximum baud rate will reduce the reading time.

If 19200 or 38400 Baud are used, the selected M-Bus master and the connected meters must
support these baud rates.

Using SND_NKE in an M-Bus master
In some M-Bus modules, data can be up to 15 minutes old when they are read. If you use the
function SND_NKE (normalize M-Bus), all modules will supply current data.
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Showing whether an M-Bus master is connected
This column shows whether an M-Bus master is connected to the PC via its USB cable.

Masters connected via RS-232 COM port are not automatically selected. However, they are always
shown as connected. 

Cancelling changes
To cancel your changes, click Cancel.

Saving changes
To save your changes, click OK.

4.4.5   The Edit Meter window

In this window, you can add a new meter to your system, change the name of an existing meter
and delete a meter from the system. This chapter shows you how to open the window and add a
new meter as well as change the name of an existing meter.

Topics:

· Opening the Edit meter window

· Adding meters
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· Possible errors while importing meters

· Changing a meter name

· Deleting a meter

· Cancelling changes

· Saving changes.

Opening the Edit meter window
You can open the window by clicking Meters in the toolbar, as shown below, or via the menu Edit
> Meters.

Adding meters
Meters with wireless M-Bus can be delivered either with encrypted reading or with unencrypted
reading.
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Adding meters with encrypted reading
In order to add meters to your system, the required information has to be imported first. 

This can be done via Import meter(s) from KEM file: For this purpose, you receive an email from
Kamstrup with a link to be used for downloading the KEM file. 

You can also import meters from "My Kamstrup" which is a customer portal from which the
program automatically collects the required information.

Click Import meter(s) from KEM file.
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Enter your customer number (to be found in the top right part of your order confirmation), and click
Import.
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Select the file that you have downloaded. The file name consists of a long string of numbers and
letters and ends with "zip.kem".

The meters are then imported automatically.

Adding meters with unencrypted reading
This function is primarily used for meters with wired M-Bus and Kamstrup 434 MHz radio. 

Select Manual in the Add meters menu.

Enter the number of the meter with the lowest serial number in Meter serial number from and the
number of the meter with the highest serial number in Meter serial number to.

Click Add.
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Errors while importing the KEM file
If you cannot import the KEM file, it could be due to one of the following errors:
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Wrong customer number
The customer number has
been entered incorrectly. Check
if the customer number has
been entered correctly. If this is
the case, please contact
Kamstrup A/S.

Too many meters in the
system
Note that the system can
contain maximum 800 meters.
If this limit is exceeded, the
system will import up to 800
meters. The remaining meters
will not be imported.

Unknown error
If an error has occurred while
generating the file, or if the KEM
file has been changed, the
meters in this file cannot be
imported. Please contact
Kamstrup A/S to receive a new
file.
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Changing a meter name
You can change the name of a meter by clicking Edit or by double-clicking the name that you want
to change. Now, enter the new name, and either click OK (this will close the window) or press the
"Enter/Return" key on the keyboard. Note that it is not possible to change a meter number. To do
this, you must delete the meter that you want to change and then add a new meter.
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Deleting a meter
You can delete a meter by selecting the meter that you want to delete, and click Delete.

Cancelling changes
To cancel your changes, click Cancel.

Saving changes
To save your changes, click OK.



USB Meter Reader

86/106Kamstrup A/S • 5512839_K1_EN_06.2022_KARN

Other details in the Edit meter window
Encryption Shows whether the system includes an encryption key (KEM file) for the

meter.
Encryption keys are used for meters with wireless M-Bus and one-way radio.

USB Reader Shows the USB Readers to which the meter is connected and which can thus
read the meter.

Master Shows the M-Bus masters to which the meter is connected and which can
thus read the meter.

4.4.6   The New group window

In this window, you can create or delete a meter group and add a meter to or delete a meter from a
meter group. This section describes how to open the window and to carry out the various
functions.

Topics:

· Opening the New group window

· Creating a meter group

· Adding meters to a group

· Removing meters from a group

· Deleting a group

· Cancelling changes

· Saving changes

Opening the New group window

You can open the window by clicking Groups in the toolbar, as shown below, or via the menu Edit
> Groups.
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Creating a meter group
To create a new meter group, click Create (1). Enter a desired name (e.g. "Zone 1"), and click
Save (2) or press the keyboard key "Enter/Return". The group has now been created, and you can
add meters to the group as described in the next paragraph.
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Adding meters to/removing meters from a group
Select the group that you want to change. When you have selected a group, use the arrow buttons
"Add" (1) or "Remove" (2) to add to or remove meters from a group.

1. The arrow button "Add" is used for adding a meter to a group

2. The arrow button "Remove" is used for removing a meter from a group

3. Here, the total number of meters in the group is shown. Note: A group can maximum contain
200 meters.
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Deleting a meter group
To delete a group, select the group that you want to delete (1). Delete the group by clicking Delete
as shown above (2). Before the group is deleted, you will be prompted to confirm. Note that only
the group is deleted, not the meters in the group (see the Edit meter window to delete the meters).

Cancelling changes
To cancel your changes, click Cancel. Note that deleted and saved groups cannot be cancelled. 

Saving changes
When clicking OK, you are prompted to save changes that have not already been saved. You will
not be prompted in case of no changes or if the changes have already been saved.
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4.4.7   The Import of meter data window

If the function module "Import/Export" is installed by means of the corresponding licence key, it is
possible e.g. to import installation addresses from a billing program.

Select the file that contains the relevant meter information.

The file must be in the format TXT or CSV.
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Configuring format for import of meter data

SETTINGS

Separator
Enter the character that is used as separator in the file to be imported.

Typically, characters such as semicolon or comma are used.

Use line limits
If you do not want to import all data from the import file, you can enter the lines that you want to
import.

Index
Here the content of the import file and the order of the different  meter values are shown. In the
example, the meter number is placed at 1 and the address at 3.

Property selection
Here you select the  meter values that you want to import and where in the import file each meter
value is to be placed.

Format
If you have previously created and saved an import format, you can select it here for reuse.
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If you want to save changes to an already created format, click .

If you want to delete an already created format, select the format, and click .

Property selection
Here you select in which order the  meter values are to be placed.

Property
Select the meter value that is to be placed.

Index
Enter the number of the placement of the current meter value.

Selected properties
Here the result of the recent selection is shown.

If the house number in the import file is placed before the address, the Set house number before
street check box must be selected.

If you want to delete an already selected index, select the index, and click .

Preview
Here it is shown how the import format is interpreted with the recent selection.

Import
When clicking this button, the result of the data import is shown.

After importing the data, it is possible to save the setup for reuse.
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4.4.8   The Thermal Disconnect (TDS) window

In the Thermal Disconnect menu, you can open and close a thermal actuator connected to M-
Bus module HC-003-22, which can be mounted in MULTICAL® 403, 603 and 803.
Note: When using Thermal Disconnect, the meter’s PP configuration must be set to 99.

Topics:

1. Name
2. Serial no.
3. On master
4. Module ID
5. Status
6. Enabled
7. Open
8. Close
9. Refresh
10. OK
11. Abort
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Name
Shows the name of the meter.

Serial No.
Shows the serial number of the meter.

On master
Shows to which M-Bus master the meter is connected.

Module ID
Shows module type and its configuration.

Status
Shows whether the actuator is open or closed.

Enabled
Shows whether the meter is enabled for Thermal Disconnect.

Open
Opens the actuator of the selected meters.

Close
Closes the actuator of the selected meters.
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Refresh
Retrieves the status of the actuators of the selected meters.

OK
Closes the window.

Abort
Stops initiated tasks.

4.4.9   The Export of meter data window

By default, reading data can be exported in the following fixed formats: XLS, XLM, TXT, CSV and
PDF. 

If the function module "Import/Export" is installed by means of the corresponding licence key, it is
possible to create individual TXT and CSV export formats.

Individual export
Settings

Separator section
Enter the character to be used as separator between meter values in the file to be exported.

Typically, characters such as semicolon or comma are used.

Enter the total number of separators to be inserted in each row in the export format.

Meter selection
Select all meters, or select a meter on the basis of a user-defined list. The user-defined list is
described further below in this paragraph.

Time limits
Choose the period from which the readings should be retrieved.

Property selection
Here, you select the meter values that you want to export and where in the export file each meter
value is to be placed.

Format
If you have previously created and saved an export format, you can select it here for reuse.

If you want to save changes to an already created format, click .

If you want to delete an already created format, select the format, and click .

Property selection
Here, you select the meter values that you want to export and their order in the export format.
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Property
Here, you select the individual meter values you want to export.

Index
Enter the number of the order placement in the export format.

Selected properties
Here the result of the recent selection is shown.

If you want to separate values from units, select Split value and unit.

If you want to delete an already selected placement, select the meter value, and click .

Preview
Here, it is shown how the export format looks with the recent selection.

Custom meter list selection
This function is used if you do not want to export all meters in the database.

All meters
Here, the meters available in the database are shown.

Select the meters from which you want to export data, and move them to Selected meters by
clicking the green arrow.



USB Meter Reader

98/106Kamstrup A/S • 5512839_K1_EN_06.2022_KARN

Selected meters
Here, the meters are shown from which data is exported.

Meters are removed by moving them back to All meters by clicking the red arrow.

Filters in the All meters menu

Via the filter function, you can select and deselect the display of meters. If you e.g. only want to
export heat meters, deselect all other meters than heat meters. Then, only heat meters are shown.
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After exporting the data, it is possible to save the setup for reuse.
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4.4.10   The New job window

In this window, you can define a list of meters to be read by a specific USB Reader and M-Bus
master, respectively. In the Kamstrup USB Meter Reader program, it is called a job. This section
describes how to open the window and define a job (meter list) for a USB Reader and an M-Bus
master, respectively.

Topics:

· Opening the New job window

· Adding a meter to a USB Reader and an M-Bus master, respectively

· Disconnecting a meter from a USB Reader and an M-Bus master, respectively

· Sending a job to a USB Reader and an M-Bus master, respectively

· Cancelling changes

· Saving changes.

Opening the New job window

You can open the window by clicking Job lists in the toolbar, as shown below, or via the menu

Edit > Job lists.

Overview
In the New job window, you can add meters or groups to a job. The window contains the following:

· A list of meters and groups not included in the job list

· A group. Note the group icon, and that you can expand the group by clicking +

· A meter. Note the meter icon

· The arrow buttons "Add" and "Remove"

· Drop-down menu listing all USB Readers and M-Bus masters in the system.

· Job list

· Number of meters in the job list. Note that a job can maximum contain 200 meters.
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Creating/changing a job (Adding meters to/removing meters from a USB Reader and
an M-Bus master, respectively).
First, select the USB Reader for which you want to create/change a job. When you have selected
a USB Reader, use the arrow keys "Add" and "Remove" to add groups to and remove groups from
the job, respectively. All changes that you make will be remembered, but not saved. Thus, you can
change the job lists of as many USB Readers and M-Bus masters, respectively, as you want
before saving the changes.

Sending a job to a USB Reader and an M-Bus master, respectively
See "Saving changes".

Cancelling changes
To cancel your changes, click Cancel.

Saving changes
To save your changes, click OK. When you have saved the changes, the new job will be sent to
the USB Reader and M-Bus master, respectively, the next time the system obtains contact with
the USB Reader and M-Bus master, respectively. Thus, you can define a new job for a USB
Reader at any time, even without having contact to the USB Reader or M-Bus master in question.
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4.4.11   The Scheduling window

In the Planning menu, select how often you want to read the meters that are active in the Job lists
menu.

Topics:

1. Read every XX minute

2. Read daily

3. Read twice a month

4. Read monthly

5. Info box

6. Automatically start scheduled reading on program start

Read every XX minute
Here, you can select a minute interval between 0 and 1440. If you select 0, a new reading starts as
soon as the previous reading is completed.

Read daily
The meters are read at midnight on each of the selected days.
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Read twice a month
The meters are read at midnight on the 15th and on the last day of each month.

Read monthly
The meters are read at midnight on the last day of each month.

Info box
Describes the function of the selected reading type.

Automatically start scheduled reading on program start
When selecting this function, USB Meter Reader automatically starts the scheduled reading when
the program is started.

4.4.12   The Set-up window

In this window, you can change the settings for your Kamstrup USB Meter Reader. This section
describes how to open the window, to change the language, to define missing meters and to save
data.

Topics:

· Opening the Set-up window

· Changing the language

· Changing the definition "Missing meters"

· Changing the data folder (path)

· Re-establishing the standard settings for viewing

Opening the Set-up window
You can open the window via the menu File > Set-up, as shown below.

The Set-up window
Here, you can change the following three settings in the Kamstrup USB Meter Reader system:

1. To change a language, select the desired language in the window below.



USB Meter Reader

104/106Kamstrup A/S • 5512839_K1_EN_06.2022_KARN

2. A change of the definition "Missing meters" means changing when data is considered to be
obsolete. Number of days is an integer that is set in the text box below.

3. All data is by default saved in the folder:

XP: "\Documents and Settings\All Users\Application Data\Kamstrup\Kamstrup
USB Meter Reader\Data".

Win7/Win10: "\ProgramData\Kamstrup\Kamstrup USB Meter Reader\Data".

This can be changed by means of the "folder browser". Note that a change of placement does
not cause the current data to be moved to the folder in question.

4. Click the Reset button if you, for example, have changed the table/list in the Data view and
want to re-establish the standard settings.

Cancelling changes
To cancel your changes, click Cancel.
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Saving changes
To save your changes, click OK.

4.4.13   The About window

In this window, you can see the current software version and the product number of your Kamstrup
USB Meter Reader system. This section describes how to open the window.

Topics:

· Opening the About window

Opening the About window
You can open the window via the menu Help > About, as shown below.
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